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Theme Installation

File Structure

Extract (Unzip) the plugin download package. Within the download package you'll find the

following file structure and contents:

knowledgepress_package/

@® knowledgepress/ (theme folder for FTP install)
@® knowledgepress.zip (theme zip file for WP install)
@® KnowledgePressManual.pdf (PDF documentation)

@® AccordionFAQManual.pdf (FAQ PDF documentation)

@® import/ (demo content import XML file)
@® knowledgepress-child.zip (child theme template)

WordPress Installation

1. Go to Appearance > Themes > Add New.

2. Click Upload Theme, locate knowledgepress.zip in your plugin download
package and click Open and Install Now.

3. Once the theme is uploaded, you need to activate it. Go to Appearance > Themes

and activate the theme.

FTP Installation

1. Using a FTP program, upload the theme folder knowledgepress located in your
plugin download package folder.
2. Once the theme is uploaded, you need to activate it. Go to Appearance > Themes

and activate the theme.

Installing Plugins

This theme requires the following plugin:

@® Redux Framework

Bundled are also optional plugins:



@® Visual Composer
@® Accordion FAQ

Once you have installed the theme you should see notification to install required plugins in
dashboard. Click on the “Begin installing plugin” link to begin the installation. Once you
install the plugins, please return to the plugin list, and activate them. That’s it, you should be

good to go.

Importing Demo Content

You can import demo content using XML file (optional). To import demo content, navigate to
Tools > Import > WordPress > Choose File select XML file located in theme download
package under import folder. Proceed with uploading the file and selecting author and

content options.

Import

Posts f you have posts or comments in another system, WordPress can impert those into this site. To get started, choose a system to
mport from below:

Documents

P Tickets Blogger nstall the Blogger importer to import posts, comments, and users from a Blogger blog.
3 Media Blogroll nstall the blogroll importer to import links in OPML format.
Pages Categories and Tags nstall the category/tag converter to convert existing categories to tags or tags to categories
Converter selectively.
Comments
LivejJournal nstall the LiveJournal imparter to import posts from Livelournal using their APL
¥ Appearance : = < ;
Movable Type and nstall the Movable Type importer to import posts and comments from a Movable Type or
73 Plugins & TypePad TypePad blog.
Users RSS nstall the RSS importer to impeort posts from an RSS feed.
f Tools Tumblir nstall the Tumblr importer to import posts & media from Tumblr using their API

WordPress

impaorter o import posts, pages, comments, custom fields, categories, and

xport file,

f the importer you need is not listed, search the plugin directory to see if an importer is available.

Setting Up Menus

To setup your menus, navigate to Appearance > Menus. Give your menu a
name and add a variety of items including pages, categories and custom links. You can
manage your menus using the drag and drop functionality and click the "Save Menu"

button.
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After setting up your menu, select Manage Locations tab and select your

menu under Assigned Menu and click the "Save Changes" button.
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Theme has two menus locations:
@® Primary Navigation (Top navigation displayed on desktops)
@ Sidebar Navigation (Sidebar navigation is primarily a mobile navigation that can

be also visible on desktops)



Widgets Areas

Global Sidebars are Header and Footer.

Global sidebars are set under Theme Options > Layout. In Layout section select main

content and sidebar arrangement and also select the width of the Primary and Secondary
Sidebar.
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Primary and Secondary Sidebars can be overridden on individual pages under page

options metabox.
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Header sidebar is global sidebar visible on all pages in header under page title. Theme has
the ability to create an unlimited custom sidebars and assign them to pages in header,

primary and secondary locations.

Screen Options Help
Dashboard Wldgets
Posts = -
Available Widgets Footer 1
FAQ To activate a widget drag it to a sidebar or dlick on it.
0 To deactivate a widget and delete its settings, drag it
Media back. Footer 2
Pages
Archives
Comments (37 Footer 3
Templates A monthly archive of your site's Posts.
1 Footer 4
Projects Calendar
| Galleries A calendar of your site's Posts. Primary Sidebar
Staff
Categories
BRI Secondary Sidebar
: 1 A list or dropdown of categories.
b Testimonials
Partners et isen | Create Widget Area |
Use this widget to add one of your custom menus
A Appearance B 4
as a widget.
Mata Create Widget Area
Widgets Lagin, RSS, & WordPress.arg links.
enus Header
Pages

Custom Theme Widgets

Recent Posts Widget

Recent Posts widget allowing increased customization to display recent posts

from multiple categories.

Popular By Comments Widget

This widget displays articles ordered by the most comments.

Popular By Votes Widget

This widget displays articles ordered by the most liked votes.

Popular By Views Widget

This widget displays articles ordered by the highest number of views they received.



Twitter Widget

Twitter widget will enable you to add recent tweets from your twitter account to
a widgetized area. You can customize the number of tweets and the follow me
from the widget settings. The widget now requires Twitter Application
"Consumer Key" and "Consumer Secret". Create your Twitter application

here: https://dev.twitter.com/apps

Page Header

Headers are set globally under Theme Options > Header. Headers can be overridden on
individual pages under page options metabox. Video background accepts only self hosted

(uploaded) videos.
Setting Up Pages

Knowledge Base Page

To set up Knowledge Base page go to Pages > Add New. Enter title

and then under the Page Attributes metabox set Template to Knowledge

Base and click Publish button to save.

After the page is saved additional metabox Knowledge Base Options will be

revealed. There you can specify and select categories to display on Knowledge Base page
template, select number of knowledge base columns displayed on page, select number of
knowledge base articles displayed per category and select display 3rd level child

categories.

Contact Page

To set up Contact page go to Pages >Add New. Enter title, content and then
under the Page Attributes metabox set Template to Contact and click
Publish button to save.

After the page is saved additional metabox will be revealed where you can
specify alternative email address and subject. The form uses by default WP
admin email or you can specify alternate email address and subject under

Contact form options metabox.


https://dev.twitter.com/apps

Visual Composer

Visual Composer page builder can be used on any page template but for full browser width
backgrounds set page template to Visual Composer. To set up Visual Composer page go
to Pages > Add New. Enter title, content and then under the Page Attributes metabox set

Template to Visual Composer and click Publish button to save.

If Visual Composer page template is selected Page Options metabox settings are not

applicable.

Page Builder: Visual Composer

Frontend Drag and drop page builder.

To install this plugin:
@® Navigate to Appearance > Install Plugins under WPBakery Visual Composer click
to Install button.

@ After installing plugin click to Activate.

To build a page, create a page and click Backend Editor
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Full Visual Composer Manual is located here:

https://wpbakery.atlassian.net/wiki/display/VC/Getting+Started
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Post Formats

The theme supports the use of different post formats in order to change the
appearance of your content. If you are familiar to tumblr, the concept is
similar.

Theme supports "Standard", "Link”, “Image”, "Video" and “Audio” post formats.

Standard Post Format

Standard post displays title and post content on articles or search page. Go to
Post >Add New, enter post title, enter post content, under "Format" metabox
select "Standard" and “Publish”.

Link Post Format
A link to another site. Go to Post >Add New, enter post title, under "Format"
metabox select "Link" and “Publish”.

Image Post Format

Image post displays title, featured image and post content on articles or search page. Go to
Post >Add New, enter post title, under "Format" metabox select "Image", under "Featured

Image" metabox upload your image and “Publish”.

Video Post Format

Video post displays title, YouTube or Vimeo video and post content on articles
or search page. Go to Post >Add New, enter post title, under "Format" metabox select
"Video". This will reveal "Video Post Settings" metabox,

enter YouTube or Vimeo embed code and “Publish”.

Audio Post Format

An audio file. Could be used for Podcasting. Go to Post >Add New, enter post title, under

"Format" metabox select "Audio" and “Publish”.



Analytics

Track article views, votes and search term. Analytics charts are available under Analytics

menu in dashboard.

Article Views

Article view analytics tract number of views (page loads) an article single page receives, this

is always enabled.. Reset view count under KnowledgePress > Articles tab.

Votes

Votes settings are located under KnowledgePress > Voting tab, this is also where all votes
across all articles can be reset. Resetting a single article can be done under Post Options

metabox on poser edit page.

Search Terms

Search tracking settings are located under KnowledgePress > Search tab, this is also

where all search terms can be reset.

Automatic Article Table Of Contents

Activate the feature on per article base on post edit page under Post Options metabox:

@ Dashboard

A Posts

Post Options

All Posts Table Of Contents

Add New

Categories m Off

Tags Display automatic table of contents on the page.

When enabled, automatic table of contents will be generated on front end from H1, H2, H3

tags.
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FAQ Posts

Fags are bundled as external plugin, to install FAQ plugin navigate to Appearance > Install
Plugins. Click Install and Activate Plugin.

Faq plugin manual is located in download package folder.

bbPress Forum

Our theme provides custom styling for bbPress forum plugin.

To install this plugin navigate to Appearance > Install Plugins under bbPress click to Install
button and activate it.

For bbPress documentation see plugin websites:

http://bbpress.org

https://wordpress.org/plugins/bbpress

Child Theme

Child Theme allows you to modify or add to the functionality of the parent KnowledgePress
Theme without directly modifying the theme files.

Child Theme template is located in the download package.

Translation

Translating Theme

1. Download and install Poedit.

2. Open the program after the installation. Click File > Open and find the original
knowledgepress.pot file located in the 1lang directory in theme root.

3. Translate all the words to your language and save your translated file in the same
("lang") directory with name of your language and country codes.

4. If your language is russian and the country is Russia, then you must save the file like
this: ru_RU.po. First parameter is a language code, second parameter is a country
code. All codes can be found here:

http://www.gnu.org/software/gettext/manual/html_chapter/gettext_16.html

1
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5. Set site language under Settings > General:

aa Users Time Format ® 4:53 pm
# Tools 4:53 PM
Settings 16:53
Custom: gia 4:53 pm
General
Documentation on date and time formatting.
Writing
Reading
Week Starts On Monday e

Discussion
Media

H y A~
Permalinks Site Language Pyccrinia v

4 W

Support

Support is only provided through external support system at http://pressapps.co/help/

If you have a pre-sale question feel free to use the item comments section on Envato.

Before contacting support please:

Read this documentation

Perform basic troubleshooting by disabling plugins and switching to default theme
to identify possible cause

Describe your problem in detail

Include links

Attach screenshot

Include your WP and FTP login where appropriate
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